Uploaded image for project: 'Kvasir/Sora'
  1. Kvasir/Sora
  2. KVASIR-57

依存プラグインを必要最低限以上に自動更新しないようにしてほしい

    Details

      Description

      インストールしたい/更新したいプラグインが依存するプラグインについて、同じartifactIdで同じか
      新しいバージョンのプラグインが既にインストール済みの場合は基本的に何もしないようにしてほしい。

      (なお、依存プラグインを必要最低限以上に先のバージョンに更新したい場合は、そのプラグインを
      改めて指定して更新できればよい。)

      ただし、SNAPSHOTについては選択可能にして欲しい。つまり、依存プラグインのバージョンがSNAPSHOT
      で、かつそれと同一のバージョンを持つプラグインがインストール済みの場合は、デフォルトだと通常の
      挙動と同じ(依存プラグインは更新対象外)だが、「SNAPSHOTについては同一バージョンのものがインス
      トール済みであっても更新する」にチェックがついている場合は更新するようにしてほしい。

        Attachments

          Activity

            People

            • Assignee:
              manhole manhole
              Reporter:
              skirnir skirnir
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: