[[SeasarJavadocProject]]
*org.seasar.framework.container パッケージのふりかえり [#hadc6c81]

ふりかえりはML上では行いづらい部分があるためWiki上でやってみるテスト。

**2006.10.29 (Sun) org.seasar.framework.container KPT@赤坂 レポート [#h7f74ed7]
作成中…

***クラスコメント [#m6d95d8b]
--クラスコメントの先頭行は句点(。)まで改行しない。
--2行目(2文目)以降については<p>タグで括る。
--HTMLタグは小文字で記述する。
--@author タグの "(Javadoc)" は除く(そして気を引き締める (^^;))。ex. @author hoge (Javadoc) ⇒ @author hoge

***メソッドコメント [#xe695c5c]
--<p>タグはつかってもいいですか?(by 米澤) ⇒ 使ってます。(先頭から2番目の文を改行させるために…by belltree)

***用語統一 [#mbbbdbdd]
|用語|コメント|
|引数定義||
|diconファイル||
|<arg>要素||
|インジェクション||
|コンテキスト||
|S2コンテナ||
|Expression||
|コンポーネント定義||
|アクセスタイプ(AccessTypeDef)|⇒アクセスタイプ定義|
|文字列表現||
|コンポーネント||
|状態||
|インジェクション||
|アクセスタイプ||
|ファクトリ||
|定数||
|バインディングタイプ定義||
|プロパティ定義||
|コンポーネント定義||

**文書表現統一 [#j3b26c6c]
|ポイント|表現|
|#getName()のコメント|"〜の文字列表現を返します" ⇒ "定義名を返します。"|
|||

**検討課題 [#a4af7a0b]
|No|課題|ステータス|検討結果|
|001|日本語・アルファベット混在の場合、括弧は全角で統一する?|保留||
|002|<arg>要素、<component>タグ などタグ要素の表現が不統一…|保留||
|003|初期化メソッド定義? initメソッド定義? ({@link InitMethodDef *})|保留|【方向性】初期化メソッド定義 にして、ペアとなる DestroyMethodDef の日本語表現を考える…|

作業中… Zz…
再開ポイント 15:02:50

** 修正項目一覧 [#ta015d6c]
|場所|内容|優先度|サインアップ|対応済み?|備考|
|全体|@authorの後の(Javadoc)を削除する。||azusa|済|未削除のものがあったので削除してコミットしました。それからInterTypeDefとInterTypeDefAwareの@autherの1人目、名前が空白だったので、履歴の最初の koichik さんで入れておきました。[belltree]|
|package.html|Smart DeployをSMART Deployに変更する。|X|goto|済|deployの"d"が小文字だったので大文字にしてみましたが…junduさんの[seasar-javadoc:682]を見て元に戻しました…ゴミ履歴残してすみません…orz [belltree]|
|AccessTypeDef/概要|サマリされる1文目の後に改行を入れる。||belltree|済||
|AccessTypeDef/全般|アクセスタイプという言葉をアクセスタイプ定義に統一する。||belltree|済|冒頭の1行に若干違和感を感じるのですが、とりあえず、コミットしました (^^;;;|
|AccessTypeDef#getName()|「…文字列表現を返します。」ではなく、「アクセスタイプ定義名を返します。」に修正する。||azusa|済|azusaさんゴメンナサイ。直しちゃいました…orz [belltree]|
|ArgDef#isValueGettable()|「…いずれかが存在する場合、trueを返します。」を「…いずれかが存在し、値の取得が可能かどうかを返します。」といった表現に変更する。合わせて、戻り値の説明を「値の取得が可能な場合、trueを返す」といった表現に修正する。||vestige|済||
|ArgDefAware#addArgDef|登録(追加)を追加に書き換える。||jundu|済||
|ArgDefAware#getArgDef()|他と統一するため、IndexOutOfBoundsExceptionの記述を削除する。||jundu|済||
|AspectDef/概要|S2AOPの後のカッコ内の記述は、Javadocに不要に思われるので削除する。||belltree|済||
|AspectDef/概要|AOP一般に関する記述は、S2Containerの公式ドキュメントに任せ、そちらへの参照先のみとする。リンクにするかどうかは課題。||belltree|済|リンクにしてあります。|
|AspectDef/概要|インターセプタを複数登録することと、InterceptorChainを使うことの違いを記述できると良い。||belltree|済|設定を簡略化できる点を追記しました。あとSMART Deploy系で、InterceptorChainじゃないと出来ないことがあったような…|
|AspectDefAware#addAspectDef|登録(追加)を追加に書き換える。||goto|済||
|AutoBindingDef/概要|サマリされる1文目の後に改行を入れる。||jundu|済||
|BindingTypeDef/概要|サマリされる1文目の後に改行を入れる。||jundu|済||
|ComponentCreater/概要|Smart DeployをSMART Deployに変更する。|X|goto|済||
|ComponentCustomizer/概要|Smart DeployをSMART Deployに変更する。|X|goto|済||
|ComponentDef/概要|インタフェースをインターフェースに統一する。(1行目)||azusa|済|azusaさんゴメンナサイ。ついでだったので修正しました。mOm [belltree]|
|ComponentDef/概要|コンストラクタ引数定義は、引数定義に修正する。||belltree|済||
|ComponentDef#getComponentClass()|サマリされる1文目の後に改行を入れる。||belltree|済||
|ComponentDef#getComponentClass()|<component/>を<component>に統一する。||belltree|済||
|ComponentDeployer/全般|コンポーネントインスタンス定義を、インスタンス定義に統一する。||belltree|済||
|ComponentDeployer/概要|インタフェースをインターフェースに統一する。(1行目)||azusa|済|azusaさんゴメンナサイ。【以下同文】mOm;;; [belltree]|
|ConstructorAssembler/概要|サマリされる1文目の後に改行を入れる。||jundu|済||
|ConstructorAssembler#assemble()|サマリされる1文目の後に改行を入れる。||jundu|済||
|ContainerConstants#PACKAGE_SEP|Javadocの記述が漏れているようです。||belltree|済|次のコメントを追加しました。意味不明の場合にはツッコミ(or修正&コミット)下さい。mOm ⇒ 『パッケージ名(Javaのパッケージとは異なる)付きコンポーネント名における、パッケージ名と自動バインディング用コンポーネント名の区切り(char)を表す定数です。』|
|DestoroyMethodDef/概要|「コンポーネントインスタンス定義」を「インスタンス定義」に統一する。||vestige|済||
|DestroyMethodAware#addDestoryMethodDef|登録(追加)を追加に書き換える。||vestige|済||
|DestroyMethodAware#addDestoryMethodDef|全体的に追加に統一する。||vestige|済||
|ExternalContext/概要|「Webコンテナなどの外部コンテキスト」に修正してはいかがでしょうか?||goto|済||
|ExternalContext#getInitParameterMap()|初期化設定値という言葉に違和感を覚えますが、いかがでしょうか? 初期設定値で通じる気がします。||goto|済||
|IllegalAccessTypeDefRuntimeException/全体|「アクセスタイプ名」を「アクセスタイプ定義名」に統一する。||goto|済||
|IllegalAccessTypeDefRuntimeException/コンストラクタ|アクセスタイプ名をアクセスタイプ定義名に統一する。||goto|済||
|IllegalConstructorRuntimeException/概要|2行目が「コンポーネントの構築は」で始まっているのは日本語がおかしい。「この例外は」の間違いと思われる。||jundu|済||
|IllegalMethodRuntimeException/概要|「適切な型にパース出来ない場合」は、「適切な型に変換出来ない場合」の方が分かりやすいように個人的には感じるのですが、いかがでしょうか?||belltree|済|確かに「変換」の方がしっくりしました。指摘ありがとうございます。mOm [belltree]|
|InitMehtodDef/概要|「1個以上の任意のメソッド」のところは、「1つ以上の任意のメソッド」に変えてみてはいかがでしょうか。個人的にメソッドを1個と数えることに違和感を覚えました。||azusa|済||
|InitMethodDefAware#addInitMethodDef|登録(追加)を追加に書き換える。||azusa|||
|InitMethodDefAware#addInitMethodDef|登録(追加)を追加に書き換える。||azusa|済||
|InstanceDef/全般|「コンポーネントインスタンス定義」を「インスタンス定義」に統一する。||goto|済||
|InstanceDef/概要|backport175アノテーションに関する記述は削除する。2.4以降でサポートされないため。||goto|済||
|InterTypeDef/概要|インタフェースをインターフェースに統一する。(1行目、実装インタフェースのところ)||azusa|済||
|InterTypeDef/概要|空の@authorを削除するか、@authorの前に誰かの名前を書いたほうが良いように思います。||azusa|済|koichikさんの名前を入れました。[無許可 (^^;; by belltree]|
|InterTypeDefAware/概要|インタフェースをインターフェースに統一する。(1行目)||belltree|済||
|InterTypeDefAware/概要|空の@authorを削除するか、@authorの前に誰かの名前を書いたほうが良いように思います。||azusa|済|koichikさんの名前を入れました。[無許可 (^^;; by belltree]|
|InterTypeDefAware#addInterTypeDef|登録(追加)を追加に書き換える。||azusa|済||
|MetaDef/概要|サマリされる1文目の後に改行を入れる。||vestige|済||
|MetaDefAware|登録(追加)を追加に統一||vestige|済||
|MetaDefAware/概要|個人的には、メタデータの取得方法の説明は、リストではなく「または」で繋ぐだけでも良い気がします。項目が2つしかないので。||vestige|済||
|MetaDefAware#getMetaDef(String name)|サマリされる1文目の後に改行を入れる。||vestige|済||
|MetaDefAware#getMetaDefs(String name)|サマリされる1文目の後に改行を入れる。||vestige|済||
|MetaDefAware#getMetaDefs(String name)|@param nameが2つ書かれているので、1つ削除する。||vestige|済||
|MethodDef/概要|インタフェースをインターフェースに統一する。(1行目)||azusa|済||
|PropertyAssembler#assemble|例外は、投げるではなくスローに統一する。||jundu|済||
|PropertyDef/概要|インタフェースをインターフェースに統一する。(1行目)||azusa|済||
|PropertyDefAware/概要|インタフェースをインターフェースに統一する。(1行目)||azusa|済||
|PropertyDefAware#addPropertyDef|登録(追加)を追加に書き換える。||azusa|済||
|PropertyDefAware#hasPropertyDef(String propertyName)|ここの説明は、「指定したプロパティ名のプロパティ定義があればtrueを返します。」ではないでしょうか。ちょっと自信ないですが。元の表現と言っている事は同じですか?||belltree|済|ここでは「プロパティ名に」より「プロパティ名の」の方が正しく意味を表していると思ったので、修正しました。ついでに、気が付いてしまったので、@param propertyName が 「プロパティ定義」になっていたのを「プロパティ名」に修正しました。|
|TooManyRegistrationComponentDef/概要|インタフェースをインターフェースに統一する。(1行目)||azusa|済||

トップ   編集 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS