[KVASIR-57] 依存プラグインを必要最低限以上に自動更新しないようにしてほしい Created: 06/Feb/07  Updated: 17/Feb/07  Resolved: 12/Feb/07

Status: Closed
Project: Kvasir/Sora
Component/s: plugin/org.seasar.kvasir.cms.manage
Affects Version/s: None
Fix Version/s: 3.0.0-RC1

Type: Improvement Priority: Critical
Reporter: skirnir Assignee: manhole
Resolution: Fixed Votes: 0
Labels: None


 Description   

インストールしたい/更新したいプラグインが依存するプラグインについて、同じartifactIdで同じか
新しいバージョンのプラグインが既にインストール済みの場合は基本的に何もしないようにしてほしい。

(なお、依存プラグインを必要最低限以上に先のバージョンに更新したい場合は、そのプラグインを
改めて指定して更新できればよい。)

ただし、SNAPSHOTについては選択可能にして欲しい。つまり、依存プラグインのバージョンがSNAPSHOT
で、かつそれと同一のバージョンを持つプラグインがインストール済みの場合は、デフォルトだと通常の
挙動と同じ(依存プラグインは更新対象外)だが、「SNAPSHOTについては同一バージョンのものがインス
トール済みであっても更新する」にチェックがついている場合は更新するようにしてほしい。



 Comments   
Comment by manhole [ 12/Feb/07 ]

r1751で、

ただし、SNAPSHOTについては選択可能にして欲しい。つまり、依存プラグインのバージョンがSNAPSHOTで、かつそれと同一のバージョンを持つプラグインがインストール済みの場合は、デフォルトだと通常の挙動と同じ(依存プラグインは更新対象外)だが、「SNAPSHOTについては同一バージョンのものがインストール済みであっても更新する」にチェックがついている場合は更新するようにしてほしい。

を実装しました。

Comment by manhole [ 12/Feb/07 ]

r1767で、install時にも↓を可能にしました。

ただし、SNAPSHOTについては選択可能にして欲しい。つまり、依存プラグインのバージョンがSNAPSHOTで、かつそれと同一のバージョンを持つプラグインがインストール済みの場合は、デフォルトだと通常の挙動と同じ(依存プラグインは更新対象外)だが、「SNAPSHOTについては同一バージョンのものがインストール済みであっても更新する」にチェックがついている場合は更新するようにしてほしい。

Comment by skirnir [ 17/Feb/07 ]

新規インストールについては確認しました。

更新については、現状の機能では確認できないので、KVASIR-102が実現できた後に
確認することにします。

Generated at Fri Aug 07 21:03:54 JST 2020 using JIRA 7.9.2#79002-sha1:3bb15b68ecd99a30eb364c4c1a393359bcad6278.